Home Forums Theme support Yooco Theme PHP version

Tagged: ,

This topic contains 36 replies, has 2 voices, and was last updated by  7Theme Support 5 years, 4 months ago.

Viewing 7 posts - 31 through 37 (of 37 total)
  • Author
    Posts
  • Thanks. It would seem strange for it to be a server setting as the old version works fine, the only difference is upgrading to the new version but if there is anything I need to tell my ghosting company just let me know.

    I’d really like to get this working as I’m planning a lot of changes to the site and dont want to do that till I have the theme working.

    Hope you guys all had a good holiday?

    Yes, but new version have a new php.ini file with new php settings, unfortunately it’s not so easy… First we have to check what settings cause the problem, then we have to consider if it’s better to write a workaround for it or if you have to contact your hosting provider.

    Hope you guys all had a good holiday?

    Yes, we had, hope you too!

    Hi – yes it was great thanks, all the family here but quiet again now lol!

    Thanks for version 1.12, however the same problems still exist – and still referring to line 192 in yooco functions.php. It has also locked me out of my WP control panel.

    Errors now are:

    Warning: Declaration of Menu_With_Description::display_element($element, $children_elements, $max_depth, $depth, $args, &$output) should be compatible with Walker::display_element($element, &$children_elements, $max_depth, $depth, $args, &$output) in /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php on line 192

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php:192) in /homepages/3/d638946344/htdocs/wp-login.php on line 394

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php:192) in /homepages/3/d638946344/htdocs/wp-login.php on line 407

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php:192) in /homepages/3/d638946344/htdocs/wp-includes/pluggable.php on line 893

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php:192) in /homepages/3/d638946344/htdocs/wp-includes/pluggable.php on line 894

    Warning: Cannot modify header information – headers already sent by (output started at /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php:192) in /homepages/3/d638946344/htdocs/wp-includes/pluggable.php on line 895

    And a little extra info – if I leave v1.12 installed and revert my php version to 5.6 then the site works but my menu is destroyed. I’ve had to revert again to version 1.05 and php 5.6

    Ok, checked again, essentially it’s a server problem.

    First thing I would do is to contact the hosting provider and ask to change the value for “output_buffering” to “on”.

    In the meantime you can use Yooco 1.13, we made a workaround for this problem, hope it helps you with the server problem.

    Hey guys – thank you so much for all of the work you are doing on this.

    Ok – version 1.13 seems to be working great – no error messages though I havent checked everything on the site yet. Last night I changed the php version to 7.0 and uploaded yooco v1.13

    I spoke to my hosting provider just now and they tell me they have now changed the setting for output_buffering to on

    You mentioned once before about switching error messages off as a security measure – please could you tell me how to do this?

    Thank you again for all your hard work – and have a very Happy New Year!

    Colin

    Hi Colin,

    first thing is to make sure in the wp-config.php file “wp_debug” is set to false, by default it is set to false, so if you not changed it, I think it should by ok.

    The command for the php.ini file is this one:

    display_errors = Off

Viewing 7 posts - 31 through 37 (of 37 total)

You must be logged in to reply to this topic.