Home Forums Theme support Yooco Theme PHP version

Tagged: ,

This topic contains 36 replies, has 2 voices, and was last updated by  7Theme Support 5 years, 4 months ago.

Viewing 15 posts - 16 through 30 (of 37 total)
  • Author
    Posts
  • Sorry for the broken link, we fixed it already. Updates for themes you can see only if you use a theme from wordpress.org, all other themes are not included in the WordPress update system.

    Ah brilliant – thank you for all your help, I really appreciate it.

    So – do I just ftp it and overwrite the existing files?

    What will happen to all my settings – colours, the settings you helped with before to fix the mouseover thing and so on?

    Thank you for the help

    Colin

    Yes, normally you can overwrite existing files, as long as you not changed the files.

    All other changes, for example the theme options and custom css code in the theme options are saved in the database

    Ok thanks for the help – I’ve just uploaded the new theme and still get errors.If I revert the php to 5.6 then the errors go away

    Warning: Declaration of menu_With_Description::start_el(&$output, $item, $depth, $args = Array, $id = 0) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php on line 192

    Hi,

    sorry for that, you are right, checked it again with the current version and it looks like we forgot to update this function. We made already an update for it with the fix, new version is 1.09 and now available

    By the way: if your website is a public website, you should really deactivate error messages. Hacker can provoke errors via URL parameter and other hacks and find vulnerabilities of your website. Never activate error messages on public websites!

    How do I do that? I havent activated them at all so it must be a default setting – the same errors also show within my WordPress admin panel

    Also – the version showing in My Downloads is still 1.08?

    Ok thanks – the new version has now been made available and I have uploaded it but unfortunately it has broken my website completely.

    I now have no access to my website, nothing at all is displayed on the page except for the message

    Parse error: syntax error, unexpected ‘,’, expecting ‘(‘ in /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php on line 190

    I will have to replace it with the older version and hope that fixes it until you guys can sort the problem

    Oh, sorry, my fault, we fixed it and uploaded the new version…

    Still get error – the new version totally kills my website and even my wp-admin panel so I cannot log in or anything.

    All i get is a blank page with

    Fatal error: Call-time pass-by-reference has been removed; If you would like to pass argument by reference, modify the declaration of apply_filters(). in /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php on line 190

    Hi,

    we checked it now on different server and we don’t get this error. You use Yooco 1.1?

    Yes that’s using 1.1

    1.11 is still the same.

    I either get:

    Fatal error: Allowed memory size of 268435456 bytes exhausted (tried to allocate 148003837 bytes) in /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php on line 190

    or I get:

    Warning: Declaration of Menu_With_Description::start_el(&$output, $item, $depth, $args = Array, $id = 0) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php on line 192

    Warning: Declaration of Menu_With_Description::display_element($element, $children_elements, $max_depth, $depth, $args, &$output) should be compatible with Walker::display_element($element, &$children_elements, $max_depth, $depth, $args, &$output) in /homepages/3/d638946344/htdocs/wp-content/themes/yooco/functions.php on line 192

    Hi,

    “Allowed memory size” is not up to the theme, it is a server setting. I suppose there is a problem with your server settings, because we tried it no on different server again and cannot reproduce the problem (both errors).

    We test it now again on another server, from a shared hosting company, because we use always our own server with perfect server settings. Shared hosting use often bad settings / very restricted settings, so maybe that’s the problem. But let us test that, I’m sure we will find the problem.

Viewing 15 posts - 16 through 30 (of 37 total)

You must be logged in to reply to this topic.