Home Forums Theme support Urban Dark theme- Changing font size theme options doesn't work

This topic contains 6 replies, has 2 voices, and was last updated by  7Theme Support 1 year, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • I am unable to change the size of the font in the “main section” of my website. I can change the fonts (for example, changing between times new roman and roboto) correctly, but changing numbers in the “px” text box and saving does nothing. It changes the size of the text in the preview box underneath text selection dropdown menu, but those changes don’t actually apply to the website after saving. I am in the “Theme Options” menu, under “Main section”, subsection “Typographie” (it’s spelled that way in the menu). Changing the font from times new roman to roboto in “main section” also changes the header menu font, so I want to be sure that changing my main section font size(used in text on pages) doesn’t change the size of my header menu text as well.

    Perhaps there is custom CSS that can do this if the menu item won’t work.

    My site’s font is very thin and difficult to read on mobile but looks good on desktop for some reason (mobile is android in firefox and desktop is windows 10 in firefox). Because of this I would like to increase the text size of my website to make readability better but it refuses to change. Website is artifact-3d.com.

    Edit: If possible, instead of making all of my fonts bigger, I would like to just make my mobile font appear as it does on desktop. As mentioned, the text shows up very thin and almost unreadable on mobile for me but looks good and thick on desktop. If I could make them match that would be a better solution. The mobile font needs to be much thicker in order to be comfortably readable, I have had another user mention the mobile font is hard to read because of how thin it is.

    Hi,

    not sure what went wrong, we will check it again. In the meantime you can try this css code, please add it in WP admin -> Appearance -> Theme Options -> General -> Extra CSS Content:

    #main {
    font-size:16px;
    }

    To be honest I cannot see a difference between the font on a desktop and the font on a mobile device, for me it’s the same. I would make the color more bright, because also than it’s better readable.

    I have tried the custom CSS, updated, and the font size is still not changing at all (I tried 16, 20, 32). I also checked in 2 web browsers (Firefox and Microsoft Edge) and font size didn’t change in either one so I doubt it’s a browser issue. Changing the background will help but I’m also interested in being able to change the size of my main font size should it become necessary in the future, and I’d like to find out why the menu option isn’t working. I’ve made sure I’m doing it in the section requested (I also tried it in the “customize” menu’s custom css area and had no effect). I’ve cleared caches, updated, refreshed, and the text size just doesn’t change at all.

    It’s odd that I’m able to change the font style but not the font size.

    Where have you added the code we gave you? We checked all css files, but did not found the code! If you want, you can send us ( info @ 7theme . net ) a login for your website, then we can check the backend for the problem, but I think there is a plugin with a website caching module…

    I removed the code as it didn’t produce any changes and I didn’t see a reason to leave code there that didn’t do anything. I have added it back now and saved it in the section you specified. I have changed it to:

    #main {
    font-size:32px;
    }

    as I wanted it be large enough to be able to notice a real difference in text size. The font size is the same size it was before I added the code back in (and checking 16 and 24 px to make sure there was still no change). If this doesn’t make the problem apparent please let me know what login info you need (just wordpress?) and I will send login info if that is the only option.

    I’ve checked my website and it looks like some text is affected by the custom CSS and some isn’t, if that helps pinpoint the issue. The code you’ve given, for some reason, only affects my bulleted lists, and not the regular paragraph text.

    Notice that the main/landing page when you visit http://artifact-3d.com/ as well as the contact, shop, galleries, and project quotes pages all have the same text sizes (this text size is never changed by the css code I’ve put in). This is regular paragraph text, not header.

    However, if you go to the Process or Services page, notice that the bulleted lists have all increased to 32 px font. This is using:

    #main {
    font-size:32px;
    }

    thank you for your help, hopefully this information can help find the problem.

    Ok, we need to make the code more precise to overwrite the preset settings, you can use this code:

    #main, #main p {
    	font-size: 32px !important;
    }

    Yes, if you send us a login, then for WordPress only.

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.