Home Forums Theme support Strong Theme not displaying correctly again

This topic contains 3 replies, has 2 voices, and was last updated by  7Theme Support 1 month, 2 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Greetings,

    It looks like my theme, Strong, is having issues again. This time it seems to affect every site that I have the theme on. I’m not sure if it’s because of issues with the newest WP version update. It’s affected the themes aesthetics. Meaning the graphical interface is making the site functional but really funky and not pretty. What is causing this? I’m using version 1.06 or 1.07. I did see that it’s up to version 1.08 but I’m not sure if this is the only issue. I’m also wondering if it’s something else like a jquery thing. This issue happened before. So I have to ask. These are the site samples that is using Strong as it’s theme. Any help is appreciated. Thanks.

    https://cccclimateleaders.org/
    http://sanleandrodemocraticclub.com
    https://sihis.com/

    Hi, we answered already your email. The problem is that your hosting provider blocks some important files, see the email with the screenshot we sent you.

    Greetings, I’ve fixed the websites in question and it seems to be working properly. I also changed hosting providers as well. Since both servers operate a little different from each other, a common issue comes up. It’s within the .htaccess file. It’s located in the wp-includes folder and the wp-admin/includes folder. The new hosts has a way to secure the directories. When it does, it creates this htaccess file.

    # BEGIN rules managed by Control Panel > WordPress
    # !!mwyYxWuq1wUDCxb5dOJ0nv+cuDk:eyJzZWN1cmUiOjF9

    ### BEGIN PHP Security rules enabled via Control Panel > WordPress ###
    Options -Indexes -ExecCGI
    # Execution prevention
    <Files ~ “\.ph(?:p[345]?|t|tml)$”>
    deny from all
    </Files>
    #### END PHP Security rules enabled via Control Panel > WordPress ####

    # END rules managed by Control Panel > WordPress

    OK, the problem, this part of the htaccess is interfering with the look and feel of the website using Strong. I delete it and it’s fine. I delete the entire htaccess file and of course it’s fine.

    <Files ~ “\.ph(?:p[345]?|t|tml)$”>
    deny from all
    </Files>

    Anyhow, I’m not sure if this piece of code is creating issues across the board, depending on the host, or not but I wanted to bring this up. I’m at a point that I have to replace the theme (most sites I have are using Strong 1.08) The other reason I suspect it’s the theme, none of my other WordPress sites using other themes are affected. They’re operating normally.

    Will an updated version be made available soon? I know that WordPress is going to come out with a major revision soon and I don’t want to keep repairing my sites because of conflicts. Thank you.

    Ok, this code in the .htaccess files is no part of WordPress, but it’s exactly the problem. Please check the directory “wp-content” and “wp-content/themes” as well, because the theme needs some PHP files.

    The Strong theme comes with a huge number of theme options, we cannot add all generated CSS code in the header of the website, that’s why we created the PHP files with the generated CSS code, many other themes do the same and with a normal hosting plan you can use it. If your hosting company make changes in the WordPress core, of course, it can create a problem…

    Will an updated version be made available soon?

    An update will change nothing because we need the PHP files. Just make sure that PHP files are not blocked in the theme folder, then there is no problem.

    I know that WordPress is going to come out with a major revision soon and I don’t want to keep repairing my sites because of conflicts.

    We update all our themes, if there is a problem with a new WordPress release we will fix it immediately

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.