It’s been a very long time since I have been on the forums. Hope all is well for the 7theme team.
I’m using the Skyline theme an it is working well. I’m using Wordfence security which is excellent. Their most recent scan has revealed I’m running the site on PHP Version 5.2.17 currently. An update to one of their features (country blocking) will require PHP be upgraded to Version 5.4.
Does the Skyline theme work on PHP Version 5.4? Any known issues with using PHP 5.4 that I need to be aware of?
They are making their update in April so I need to upgrade PHP prior to that. Their Country Blocking feature is excellent in preventing hacking from certain countries and I would like to keep using this feature, but will need to upgrade to PHP 5.4 to do so.
Actually an update/additional questions regarding PHP…
Here is the text from the message from Wordfence:
• Details: The GeoIP database that is required for country blocking is being updated to a new format in April 2018. This new format requires sites to run PHP 5.4 or newer, and this site is on PHP 5.2.17. To ensure country blocking continues functioning, please update PHP prior to that date. Get more information.
So it can even be a newer version of PHP. My preference would be to go to one of the more recently supported/stable versions (e.g. 7.1 or 7.2). When I checked it out the earliest version I can upgrade to is 5.6 but security support is ending in December 2018.
What is the most recent version of PHP that the Skyline theme will work under? I’m hoping I can go to 7.2.
Was PHP delivered with the theme or was that part of my WordPress install by my web hosting company?
no worry, it’s compatible with PHP 5.4, you can make the update 🙂
You must be logged in to reply to this topic.