Home Forums Theme support Skyline Theme: Google Maps Work on Object Pages, not In Search Results

This topic contains 3 replies, has 2 voices, and was last updated by  7Theme Support 3 months, 1 week ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • Hello!

    We are having a problem with some of the Google Maps on the Skyline Theme.

    We have working Google Maps on the /home-featured-objects/ page and on the individual Object pages, but the Search Result Pages show the Google Map at the top of the page with a box over the Map that says, “This page can’t load Google Maps correctly.” and the map underneath it says “For Developer Purposes Only” multiple times.

    The Google Maps API Key was verified and re-entered, and we still have the same problem on the Search Results pages. What is the problem and how do we fix it?

    We are about to go live and send out marketing e-mails to Real Estate Brokers and this is the last piece of the puzzle we need to fix.

    Hi,

    thank you for your post. Do you use the latest version of the theme? Can you send us a link to the page with the problem?
    Thank you!

    Hi.

    We appreciate the quick response!

    We are running Skyline Version: 1.17 and there is no update notice on the Dashboard.

    Any search result page has the Google Maps Error:
    https://www.philippinebeachproperties.com/?stype=research&s=re&paged=1&captcha=&estate_type=180&estate_kind=174&estate_country=-1&estate_city=-1

    Even though the Google Map works at the bottom of this page, any search combination from the top section has the same Google Maps Error (above):
    https://www.philippinebeachproperties.com/home-search/

    Google Maps also works correctly on all individual Object pages:
    https://www.philippinebeachproperties.com/estate/sale-6th-floor-unit-d-one-pacific-mactan-newtown-cebu/

    I have deleted and re-added the API Key multiple times to no avail.

    Any help will be appreciated…

    Hi,

    we chedked it, looks like we forget to remove the sensor URL parameter in the last update (deprecated by Google). that’s why the map on the search result page is not working. We will fix this as soon as possible and provide an update.

    If you want, you can send us (info @ 7theme . net) a login for your website, then we can remove the URL parameter directly in your PHP files, so you don’t have to wait for the update, and of course, you don’t have to update the theme.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.