Home Forums Theme support Responsive Design

This topic contains 6 replies, has 3 voices, and was last updated by  7Theme Support 4 years ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • Ich benutze das Hotel Theme “Parador” und bin begeistert. Allerdings funktioniert die Darstellugn auf dem Smartphone nicht richtig. Beim “mobile friendly test” von Google fällt die Seite auch durch.
    Hier der Link: http://www.gabelmacher.de

    “Enable responsive design – Check this box if you would like to enable the responsive design”
    Diese Funktion ist aktiviert.

    Können Sie helfen?
    Besten Dank
    Thomas

    Hallo Thomas,

    wir haben uns das angesehen und es sieht so aus als ob der Viewport Meta Tag im Header fehlt, meistens wird soetwas durch plugins verursacht.

    Man kann das ganze einfach beheben indem man in der Datei “functions.php” folgenden Code an das Ende einfügt:

    function sl_handle_viewport_error()
    {
    echo ‘‘;
    }
    add_action(“wp_head”,”sl_handle_viewport_error”);

    Vielen Dank für die Info. Ich habe das versucht und den Code eingebunden und zwar unter: wp-content/themes/parador/functions.php

    Leider hat das dennoch nicht funktioniert. Habt Ihr noch einen Tipp woran das liegen kann? Soll ich Euch in einer Nachricht die Zugangsdaten schicken?

    Ich hätte noch eine andere Frage. Wo kann ich die Bilder der “Quickgallery 4 col” austauschen. Ich habe keinen Bezug gefunden der einen Rückschluss lassen würde wo die Bilder einer bestimmten Galerie zugeordnet werden können.

    Besten Dank für Eure Hilfe
    Thomas

    Hallo,

    Soll ich Euch in einer Nachricht die Zugangsdaten schicken?

    Ja, das macht die Sache denke ich etwas einfacher…

    Ich hätte noch eine andere Frage. Wo kann ich die Bilder der “Quickgallery 4 col” austauschen. Ich habe keinen Bezug gefunden der einen Rückschluss lassen würde wo die Bilder einer bestimmten Galerie zugeordnet werden können.

    Normalerweise auf der Seite selbst. Ist die Quickgallery mit einem “page template” gemacht worden oder mit dem Shortcode ( [quickgallery id=”xxx”] ) ?

    Gleiches Problem hier auch. Füge ich

    function sl_handle_viewport_error()
    {
    echo ‘‘;
    }
    add_action(“wp_head”,”sl_handle_viewport_error”);

    funktionier gar nichts mehr. Ich komme nicht mal mehr auf die Homepage (Fehlercode 500).

    Gibt es eine Lösung?

    Hallo,

    also, die Datei in welche der Code eingefügt wurde manuell herunterladen und den eingefügten Code wieder entfernen.

    Das größte Problem ist das die ” Zeichen umgewandelt werden in Unicode Zeichen, die von PHP nicht akzeptiert werden, deshalb der Fehler. Am besten vorher den Code in eine einfache Text Datei kopieren und dann die >> ” << Zeichen von Hand einfügen.

    Schau mal, das ist der passende Code / Function, wir haben es als “Code” markiert, nun müsste es mit Copy & Paste gehen:

    function sl_handle_viewport_error(){
    	echo '<meta name="viewport" content="width=device-width, initial-scale=1, minimum-scale=1" />';
    }
    add_action("wp_head","sl_handle_viewport_error");
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.