Home Forums Theme support Procare theme showing error when upgrading from PHP 7.3 to PHP ver 8

This topic contains 7 replies, has 2 voices, and was last updated by  7Theme Support 1 month, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • Hello, WordPress is reporting an error with the Procare Theme when I upgraded from PHP 7.3 to PHP 8.0.26 –

    ———————

    Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.
    In this case, WordPress caught an error with your theme, procare.
    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 6.1.1
    Active theme: procare (version 1.0)
    PHP version 8.0.26

    ——————–

    I have searched the forum and tried to find if there is a newer version of this theme with no success. I’m wondering if anybody else has had the same issue or if there is a solution to the PHP upgrade?

    Hi, thank you for your post. What exactly is the error message? Do you use plugins?

    Yes, I use several plugins. I have deactivated all of them. Then when I upgrade the PHP from 7.3 to PHP 8.0.26 I get the following fatal error when trying to load the site –
    “There has been a critical error on this website.”
    and nothing else on the home page. When I go back to PHP 7.3 the site loads just fine.

    Wordpress reports the following via email –
    —————-
    “Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.
    In this case, WordPress caught an error with your theme, procare.”
    —————

    In this website WordPress is not reporting any issues with any of the plugins, just the theme – procare. Out of 25 other websites that I upgraded the php with (mostly Avada and Divi themes) There was 2 issues reported. 1 plugin was reported as an issue (WooCommerce Subscriptions) and 1 theme – procare. I only have 1 website with this theme. All the other sites upgraded with no issues.

    Hope this helps

    Ok, now I saw the problem, in your first post I saw your are using version 1.0 of the theme, this is the version of the first release, in the meantime we made some updates. If you purchased the theme on our website 7theme.net you can download the most recent version of the theme in your account, normally, as soon as you upload the updated version it should work fine.

    Hi 7Theme,

    I purchased a legitimate copy of the ProCare theme as part of a 7Theme 15 Premium WordPress Theme bundle from DealFuel. I only ever used the ProCare Theme from this bundle – one time – for 1 client. I see that you state about your bundles “All WordPress themes in the bundles come with free support, free updates, and commercial licenses.” When I look in my 7tTheme account there is nothing to download. Is there any way I can download the later version of this theme?

    Many thanks, freewillie

    Ok, can you please contact our support via info @ 7theme . net, then we can try to find your purchase. Thank you.

    Hi 7Theme,
    I have now sent 2 emails with all my details and purchase information to info@ as you suggested. There has not been any response to either emails. Can you give them a nudge?

    Many thanks,

    William Mills

    Hi William,

    today we answered via email, and attached the theme to your account.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.