Home Forums Theme support Problem with Allslider width

Tagged: ,

This topic contains 12 replies, has 2 voices, and was last updated by  7Theme Support 6 years, 3 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • Hallo,

    bei der Seite http://agvs.at/literatur ist das Bild im Allslider zu groß. Wie kann ich erreichen, dass es sich der Bildschirmbreite anpasst.

    Danke im Voraus!

    Gruß,
    Dominik

    Hi Dominik,

    also den Slider (Smoothslider) den du verwendest ist eigentlich genau dafür gedacht, Bilder anzuzeigen die breiter sind als der Bildschirm. Hast du mal den normalen (Cycle Slider) versucht, der müsste eigentlich das komplette Bild anzeigen…

    Sorry, ich habe vergessen auf Cycle zurückzustellen. Aber eigentlich ging es genau darum. Dort funktioniert es nämlich nicht. Ich habe es nochmal auf Cycle zurückgestellt.

    Hallo Dominik,

    ich habs grad nochmal auf unseren Server mit deinen Bilder getestet, schau mal bitte hier:

    http://7theme.com/wp5/?page_id=2

    Sobald du 2 Bilder im Slider hast bewegen sich die Bilder (Ich hab nur zum testen zwei mal das selbe Bild hochgeladen). Ist das ok für dich? Wenn nicht schauen wir mal ob wir das mit eine paar Zeilen CSS Code hinbekommen…

    Also am liebsten wäre mir ein einfaches width 100% 🙂

    Vielen Dank, dass Du Dir für mich so eine Mühe gemacht hast.

    Ich habe auch erst versucht das selbst zu machen, aber intuitiv hätte ich jetzt cylce_element_content auf width 100% gesetzt. War es aber schon. Mh. Da bist Du der Profi!

    Kein Problem, dafür sind wir doch da. Also, der Slider arbeitet mit Hintergrund Bildern, die blenden wir zuerst mal aus:

    .cycle_element {
    background: none !important;
    }

    Danach setzen wir die Opacity für das eigentlich Bild wieder auf 1 statt auf 0, das haben wir im Slider gelassen um die richtige Höhe zu bekommen, dann mit Opacity=”0″ wieder ausgeblendet damit man den Effekt mit dem Hintergrund Bild sieht. Also Opacity des Bildes wieder auf 1:

    #cycle_header img {
    opacity: 1 !important;
    max-width: 100%;
    }

    Wenn du die zwei CSS Codes in den Theme Options -> Extra CSS Content eingibst sollte es eigentlich funktionieren.

    Ich danke Dir viemals! Hat geklappt.

    Gern geschehen!

    Hallo,

    ich habe noch ein Problem mit dem Slider. Dieser wird zwar mit max-width 100% angezeigt, aber ist von der Höhe auf dem Mobiltelefon genau wie auf dem Desktop PC. Wie sorge ich dafür, dass dieser richtig skaliert wird?

    http://agvs.at/literatur/

    Vielen Dank.

    Hallo Dominik,

    ich denke das liegt an der Höhe der Bilder, danach wird auch die Höhe des Sliders berechnet.

    Kannst du mal folgendes in “extra css content” in den theme options hinzufügen:

    #cycle_header img {
    height:auto !important;
    }

    Wir haben es mit dem Live Inspektor in Google Chrome auf deiner Seite getestet und da hat es funktioniert.

    Vielen Dank erstmal.

    So sieht es auf dem Handy aus:
    http://agvs.at/DEL.png

    Nun also schon etwas besser, aber noch nicht richtig.

    Gruß,
    Dominik

    Hab dir gerade die Lösung via mail geschickt…

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.