Home Forums Theme support PHP8.1- inactive and not clickable theme options

This topic contains 11 replies, has 2 voices, and was last updated by  7Theme Support 1 year, 3 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • Hello,
    Can you help me to solve this problem please?
    After changing to the newest PHP version (8.1), using apache 2.4 – I cannot click on items in theme options..
    Cause this, visual of website has changed as well.

    I am using ZenVersion: 1.07, is there any new version?
    How can I solve this problem to get it work on PHP 8.1 ?

    Thank you for a response
    best regards
    Jan

    Hi Jan, the most recent version is 1.08, as soon as you update the theme it should work again.

    Hi, thank you for a message.
    Yes, this new version of theme works 🙂

    Can I set a notification about new theme version please? By email?
    I didnt know that new update exists
    Thanks

    Yes, we will add you to the mailing list for the theme updates. I’m glad it’s working now.

    Yes, we will add you to the mailing list for the theme updates. I’m glad it’s working now.

    Hello, thank you,
    Now, is my account set to get notification about updates via mail ?
    Also I have got no notification when you have replied to this post.. although I have checked notify me of follow-up replies via mail

    Jan

    Yes, we installed the update notification for your theme. Have you also checked your spam folder for the missing email?

    Hello,
    can u type me please words of mail subject – how can I look for the email?


    Also I have noticed please, When I click on SAVE button in Theme options / BODY
    I see a pop up message: Name of the page says error , I tried to changed background picture, tried using samples and so on… I had to go CTRL+ F5 to clear message.

    Background has been changed successfully but there is annoyoing message of error after click on save button..

    How can it be fixed please?

    here is the error log

    Error Details
    =============
    An error of type E_ERROR was caused in line 181 of the file /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-content/themes/zen/7league/options-page.php. Error message: Uncaught TypeError: count(): Argument #1 ($value) must be of type Countable|array, string given in /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-content/themes/zen/7league/options-page.php:181
    Stack trace:
    #0 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-content/themes/zen/7league/options-page.php(216): sevenleague_save_input()
    #1 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-includes/class-wp-hook.php(308): sevenleague_add_adminpanel(”)
    #2 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-includes/class-wp-hook.php(332): WP_Hook->apply_filters(NULL, Array)
    #3 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-includes/plugin.php(517): WP_Hook->do_action(Array)
    #4 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-admin/includes/menu.php(155): do_action(‘admin_menu’, ”)
    #5 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-admin/menu.php(428): require_once(‘/data/3/b/3b9c0…’)
    #6 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-admin/admin.php(158): require(‘/data/3/b/3b9c0…’)
    #7 /data/3/b/3b9c04cc-ef4f-4786-8176-dde7d82fbd6d/dotykslnka.sk/web/wp-admin/themes.php(10): require_once(‘/data/3/b/3b9c0…’)
    #8 {main}
    thrown

    Hi,
    you made the update of the theme, right? Because we checked the error codes in your last post and it looks like you are using an older version of the theme. If you want, you can send us ( info @ 7theme . net ) a login for the website, then we can check it for you.

    Hello, it is updated to ZEN v1.08 , it is the last version of the theme, isnt it ?

    I clicked on BODY in theme options and set to this background – URL https://www.dotykslnka.sk/wp-content/uploads/2023/03/Spring_Flower_85399171__91177.jpg

    After save page shows an error message, it looks like something wrong is related to dashboard panel of theme after clicking on a save button…

    I am now on 1.08 Theme version
    What should it be please?

    Yes, it is the most recent version. Strange! Can you send us a login for the website? Then we can check the files, maybe there went something wrong during the theme update. Thank you.

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.