Home Forums Theme support PHP 7.1 & 7.2 dosent work

This topic contains 18 replies, has 5 voices, and was last updated by  7Theme Support 2 years, 5 months ago.

Viewing 4 posts - 16 through 19 (of 19 total)
  • Author
    Posts
  • Hello,
    I have got very similars errors on Zen Theme, which I have bought today.
    I am using localhost – wampserver. When I choose a version 7.2.14 or 7.3.1 the theme doesn´t work.
    Please help me, I paid for it, what to do to get it work? How can it be fixed? Thank you

    These errors occured:

    2x times this error
    Warning: count(): Parameter must be an array or an object that implements Countable in
    C:\wamp64\www\wordpress\wp-contents\themes\zen\7league\config.php on line 57

    2x times this error
    Warning: count(): Parameter must be an array or an object that implements Countable in
    C:\wamp64\www\wordpress\wp-contents\themes\zen\7league\config.php on line 199

    2x times this error
    Warning: count(): Parameter must be an array or an object that implements Countable in
    C:\wamp64\www\wordpress\wp-contents\themes\zen\7league\sidebars.php on line 66

    Hi,

    please note that these messages are only warnings and no errors, the website/theme is working without any problem. The problem is the configuration of the server, normally these messages should never be visible because this information is only for developers. Such kind of information is very sensitive because a hacker can provoke such messages and hack your website. On on working website, PHP errors and warnings should be deactivated always. As soon you deactivate PHP errors and warnings in your PHP settings your website will not show you anymore these messages.

    The login dosent work anymore. so
    as you recommended, i updatet al the files in the hot folder.
    The result is this error message:

    Fatal error: Uncaught Error: Call to undefined function sl_framework_loaded() in /srv/www/vhosts/vida6.ch/httpdocs/wp-content/themes/vida6/7league/anonym.php:3 Stack trace: #0 /srv/www/vhosts/vida6.ch/httpdocs/wp-content/themes/vida6/7league/init.php(64): require_once() #1 /srv/www/vhosts/vida6.ch/httpdocs/wp-content/themes/vida6/functions.php(3): require_once(‘/srv/www/vhosts…’) #2 /srv/www/vhosts/vida6.ch/httpdocs/wp-settings.php(329): include(‘/srv/www/vhosts…’) #3 /srv/www/vhosts/vida6.ch/httpdocs/wp-config.php(86): require_once(‘/srv/www/vhosts…’) #4 /srv/www/vhosts/vida6.ch/httpdocs/wp-load.php(37): require_once(‘/srv/www/vhosts…’) #5 /srv/www/vhosts/vida6.ch/httpdocs/wp-login.php(12): require(‘/srv/www/vhosts…’) #6 {main} thrown in /srv/www/vhosts/vida6.ch/httpdocs/wp-content/themes/vida6/7league/anonym.php on line 3

    This is incredibly difficult
    Give me a solution that realy works…

    Hi,

    we checked it again and on our end, it is working, but we saw that in your error message a function we deleted in the last update. Please try this: delete your browser cache, download the file again from our website and upload it again. Important: Always overwrite the old files. I remember a similar problem with another client, the problem was the browser cache, the client downloaded always the wrong file, saved in the browser cache.

Viewing 4 posts - 16 through 19 (of 19 total)

You must be logged in to reply to this topic.