Home Forums Theme support Letters Theme: Issue with blog posts only showing on first page

This topic contains 12 replies, has 2 voices, and was last updated by  reeklein 4 years, 8 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • Hello,

    I now have more posts than will display on the home page. There is a Page 2 below the home page blog list but when you click it, it displays the same posts as on the first page.

    I tried both blog list and blog grid but the same problem occurs. I tried increasing the number of posts on the page from 10 to 12 but only six will show.

    The site is http://www.PrivateLabelPreneur.com

    Any suggestions on how to fix this?

    I prefer the blog grid and would like 12 posts per page.

    Thank you,
    Ree

    Hi Ree,

    maybe it’s a problem with the permalink settings. Can you try this? Go to WordPress admin -> Settings -> Permalinks and set it to “Default”, then go to your page and try it again, and tell me if it’s working. Thank you

    If I change that setting to “Plain” (there is no “default”), will it reset the page URLs for the existing posts/pages? That will mess up my SEO.

    Yes, it will reset the page urls, but it’s only for testing. I want to see only if it’S working after this step. You can change if after to your custom permalinks, its only for testing

    Can you test this on your side? I’m afraid of breaking external links I already have pointing to my site. I’d have to go into each page/post and write down the URL to make sure I get it back the right way before changing the default. That’s a lot of work on my part to do this test. Please do the test on your side if possible. You must have a domain you use for testing…

    We’ve tested it already on our website (and 5 other server + 2 on localhost), and it’s working without any problem.
    No worry, you can change it for a moment, you don’t destroy your url settings, it’s save in the database. If you change it again to your custom permalink settings all we be there again.

    Hi there. I changed the permalink option to “Plain” and while that fixed the pagination problem, I’m now back to the problem of having my right sidebar duplicated.

    If you recall, you created a plugin for me to correct that problem and add some functionality I wanted (top advertising area, search box in the menu bar, etc.).

    Could that plugin be causing the pagination problem? If you install the plugin and add 8 posts, you could test for that on your end.

    Since my external links are now broken, I’m going to return my permalink setting to what it was and wait for your reply.

    Thank you,
    Ree

    If you recall, you created a plugin for me to correct that problem and add some functionality I wanted (top advertising area, search box in the menu bar, etc.).

    I, yes, I remember!

    Could that plugin be causing the pagination problem? If you install the plugin and add 8 posts, you could test for that on your end.

    Normally no, it doesnt change the permalink settings or the pagination code, but I will test it.

    Since my external links are now broken, I’m going to return my permalink setting to what it was and wait for your reply.

    Of course, it was only for testing…

    Thank you, I’ll stay tuned for more!
    Ree

    After hours of searching for the problem we found it: it’s still not possible, WordPress will always block permalink “page” requests on the homepage. You can try it yourself, just search in Google for the problem.

    Our developer will create a special front-page template for you, we’ve tested it already on our server and with this file it’s working…

    Wow…that’s crazy! It seems like a lot of people would have this same problem since putting the keyword in the URL is a typical SEO practice.

    Thank you for working to figure out the problem and i’ll be on the lookout for the new template.

    Thank you,
    Ree

    I’ve send you the file via mail…

    Thank you, I made the changes you outlined and it now appears to be working fine. I really appreciate the help!

    I’m inserting your instructions below so they’ll be available should I need them in the future (or someone else might find them useful).

    ………..from your email………
    I’ve attached the page template called “front-page.php” to this mail. You can upload it in the root of the theme folder.

    The only thing you have to do after this step is to go to WordPress admin -> Settings -> Reading and set the option “Front page displays” to “Your latest posts”.

    Sorry again for this, but it’s a problem with WordPress itself and we cannot change the way WordPress handle this.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.