Home Forums Theme support Justice theme – Team page images are huge

This topic contains 19 replies, has 5 voices, and was last updated by  7Theme Support 5 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • In the team page, images garishly huge, whether set via “set featured image” or linked in the page text. Unlike an ordinary page, e.g., the “default” template, editing the size of the image has no effect–it’s always huge.

    How is the size controlled? I want to use a simple 225×150 headshot image and it should render without scaling (unless of course its rendering on a small device like an iPhone, where it should scale smaller)

    Thanks

    Hi,

    normally the images are always as big as the wrapping container, it never should be bigger. We’ve tested it with the theme, on this page http://web-rockstars.com/justice/?team=ted-test the featured image is 2000 x 1300 pixel but shown with a size of 588 x 392, its working also without any problem, so I’m not sure what went wrong on your site.

    Can you send us the link to the page with the problem, then we can take a look at it.

    Thanks. The image in our page behaves as in your link, and it appears the them is behaving properly. But, the issue is this: we don’t want the image to fill the container — we want it to remain at its original size because we’re using headshots, which should be small. Is there a way to prevent an image, here, a small headshot sized at 225×150, from expanding to fit the container? Surely there is a spot in style.css or perhaps one of the team phps that could be modified to change the default behavior for team pages. Many thanks for your kind assistance.

    One additional point. As noted in my original post, an image inserted into the body of the team page (not the featured image) should be controlled by settings in the image edit menu (the one that specifies left-center-right justification, and importantly, image size). Instead, those settings are ignored, and the image expands to fill the container in exactly the same way as the featured image. This seems like a bug. Thanks again.

    Please see http://www.siliconedgelaw.com/team/ttest/

    Hi,

    you can edit the file “team-entry.php”, go to line 60 and replace this:

    <div class="team_entry_img"><img src="<?php echo sevenleague_image_url($post->ID, load_option("team_thumbnail") ); ?>" alt="" /></div>

    with this:

    <div class="team_entry_img"><img src="<?php echo $large_image_url; ?>" alt="" /></div>

    This change will display the original image in the team entries.

    The second issue you can solve when you go to WordPress Admin -> Appearance -> theme Options -> General -> Extra CSS Content and add this code:

    .single-team .post-content img {
      width: auto;
    }

    Sorry for this issue, we will fix this with the next update.

    Thank you for those edits. I’ve applied them, but there is no change to the behavior. Please see here: http://www.siliconedgelaw.com/team/ttest2/

    Thank you.

    Hi,

    I’ve checked your file with the custom css, thats what I found:

    .single‐team .post‐content img {
       width: auto;
    }

    Can you replace the “— signs in the code above with the “-” sign, then it works.

    It looked correct in the editor, however, I re-entered the code, and now it works as to the image added via the “add media” button. The featured image, however, still renders at full container width. How can we make the featured image render at native size?

    Thank you.

    Hi,

    sorry, my fault, you need to add also this code in the Extra CSS Content field in the theme options:

    .single_team .index-item-img img {
    width:auto;
    }

    Sorry, normally the images are big enough to fit the container size…

    That code succeeded. Many thanks for your help.

    Ok, great, I’m glad its working now.

    Hello! I’m having the same issue on the Lambada theme. I want my instructors pictures to remain the small size and not fill the container. I did use the code that you listed in the previous post and changed TEAM to INSTRUCTOR. It didn’t work. Is there another name it’s called?
    Loving the theme though… looking great!

    Hi Gretchen,

    sorry, but for “Instructor” you need another code as for “Team”. You can try this code:

    .single-wcs3_instructor article .single-portfolio-image img {
     width:auto;
     margin:0px auto; /* will center the image */
    }

    How do I get the instructors to show on a page that I have added, I do not see a Instructor template in the Lambada theme?

    Hi,

    there is no template, only the shortcode:

    [instructor_grid items=”9″ columns=”3″]

    Please read also the theme documentation, all the special shortcodes and features are listed in the theme documentation.

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.