Home Forums Theme support Google fonts incorrectly linked in theme

This topic contains 7 replies, has 2 voices, and was last updated by  7Theme Support 1 year, 10 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • In the theme Candy, I have discovered that Google Fonts are incorrectly in some files. The Google fonts should be called with

    <link href=’//fonts.googleapis.com/css?family=Dosis:400,700′ rel=’stylesheet’ type=’text/css’>

    and NOT with

    <link href=’http://fonts.googleapis.com/css?family=Dosis:400,700′ rel=’stylesheet’ type=’text/css’>

    If called the incorrect way, this theme does not work under HTTPS (SSL).

    The incorrect linking happens in the following files
    7league/options-page.php
    7league/script/admin.js

    Could I ask the developers of this theme to change this, and post an update to the theme?

    With kind regards/
    Johan

    Hi Johan,

    normally the theme load the webfonts (google) with a special script, delivered from Google itself, that’s why it should work, no matter if you us ssl or not. When you take a look at the source code of our demo website you can see it, here is the entry for the stylesheet file of the font:

    <link type='text/css' rel='stylesheet' href='//fonts.googleapis.com/css?family=Dosis:regular%7CPTAlegreya+Sans:100%7CPTAlegreya+Sans:900%7CPT' />

    Doesnt it work on your end?

    You are correct that is the way it should be linked. But if you do a “grep -r ‘http://fonts.googleapis’ * from the root folder of your theme, you will find that there are 4 instances that link to the Google fints in this way, twice in 7league/options-page.php, and twice in 7league/script/admin.js.

    Could you search for it yourselves in your code, and try to locate these four instances, and change them? I have already changed them myself in my copy of the code obviously, but it would be good for everyone if it was corrected in the master code as well.

    Hi Johan,

    yes, you are right. First we made all our themes with this solution. But once there is a javascript problem with another plugin, the Google script / webfont loader was not working anymore, thats why we were constrained to add the classic “HTML” solution in case there is a javascript problem with a plugin (and very much plugins are causing javascript problems). I’ll speak with our developer, maybe we can find a way to add the fallback with a actions, then you can remove the action in your functions.php file.

    Ok, I understand that might be the case. But it’s really not an option to use the HTTP in my view, since it is then not possible to use your theme at all on a site that is secured with SSL (https). Considering that escorting is a little sensitive, I am sure most of your clients will want to run this theme under HTTPS. If that is the case, you *have* to change these references – otherwise the theme becomes useless.

    Would you please reconsider, and make sure to change this?

    Oh, yes, your are right, for the “fall back” we should check if it’s http or https. We will fix this as soon as possible and upload an update for the theme.

    OK, thank you for this.

    When would you expect to have an update ready? It would be great if you could install and test the new update on an HTTPS website, to make sure it works fully under HTTPS. If you would like me to I can offer to set up a test website for you?

    At the moment we do the last test for the update. If you want and if you have the possibility, you can set us a WordPress installation on your server to test it and to make it compatible with your hoster, to make sure on your server is all working, and to find the problem. You can send us the login information via mail ( info @ 7theme . net)

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.