Home Forums Theme support Eastend theme : search form use

This topic contains 7 replies, has 2 voices, and was last updated by  7Theme Support 7 years, 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • Dear all,

    A quick question about the research page and form please.

    I added a new city and asked to display all objects linked to this city.

    Unfortunately, the result page don’t display the map (in map_container).
    Strangely, if I ask to display all object in new york (object linked to the EASTEND-DEMO-XML), the map is displayed.

    The <div id=’map_canevas’> is emplty with the new city search, and is full with the new york search.

    Last information, the google map setup for my new city is correct, the google map is correctly displayed in the detail page of the object.

    Do you have an idea ?

    Thanks a lot as usualy 🙂

    Hello,

    yes, thats strange. Can you send me the URL to the page?

    Hello

    Many thanks for wour reply.
    Now, I’m testing my website in local.

    The only thing that change is the estate_city key

    New york city selection : result OK, map is displayed
    http://localhost/wordpress/?stype=research&s=re&paged=1&captcha=&estate_type=-1&estate_kind=-1&estate_city=143

    ANgevillers city selection (new city created) : result not OK, no map displayed
    http://localhost/wordpress/?stype=research&s=re&paged=1&captcha=&estate_type=-1&estate_kind=-1&estate_city=167

    Could you perhaps just explain me wich code is calling whith the following form ? This information will allow me to do more test and keep you posted

    <form method=”get” action=”http://localhost/wordpress”>
    <input type=”hidden” name=”stype” value=”research”>
    <input type=”hidden” name=”s” value=”re”>
    <input type=”hidden” name=”paged” value=”1″>
    <input type=”hidden” name=”captcha” value=””>
    <label for=”estate_type”>Type: </label>
    <select name=”estate_type” id=”estate_type” class=”postform”>
    <option value=”-1″>Quel type de transaction</option>
    <option class=”level-0″ value=”152″>A vendre</option>
    </select>
    <label for=”estate_kind”>Type: </label>
    <select name=”estate_kind” id=”estate_kind” class=”postform”>
    <option value=”-1″>Quel type de bien </option>
    <option class=”level-0″ value=”115″>Appartement</option>
    <option class=”level-0″ value=”157″>Suite</option>
    </select>
    <label for=”estate_city”>Ville: </label><select name=”estate_city” id=”estate_city” class=”postform”>
    <option value=”-1″>Quelle ville cherchez vous</option>
    <option class=”level-0″ value=”167″>Angevillers</option>
    <option class=”level-0″ value=”143″>New York</option>
    </select>
    <input type=”submit” value=”Je lance ma recherche ” class=”square sc_button custom medium”>
    </form>

    Thanks a lot for your help

    Franck

    Hi,

    sorry, I have to rebuild it to find the error. I write you tomorrow as soon I have found it.

    Dear all,

    I revert to you for the above issue.

    Could you please have a look to the following adress

    http://immoovation.com/?page_id=13

    if you use the search form (at bottom of the slider), choose one filter (or more), clic on the green button ‘je lance ma recherche’, you will have one result but not google map displayed on the top of the screen

    http://immoovation.com/?stype=research&s=re&paged=1&captcha=&estate_type=4&estate_kind=9&estate_city=8

    there is no map displayed under the logo .. perhaps do you have an idea ?

    Once again, many thanks for your help

    regards

    Hi,

    sorry for the late answer, we had some problems today with our internet connection. Now we have found the problem.

    The address for the property is:

    rue d’Escherange

    The ” ‘ ” sign breaks the javascript code for the Google map. Maybe you can use the ” ` ” sign instead of the ” ‘ ” sign?

    Perfect!!

    Many thanks for your solution 🙂

    You’re welcome!

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.