Home Forums Theme support Crossfit – How to change fonts to display latin letters ?

Tagged: 

This topic contains 13 replies, has 2 voices, and was last updated by  7Theme Support 5 years ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • Hello

    I translated my Crossfit theme into Polish, but now I have problems with Polish letters such as ą, ę, ś, ć, ż, ź, ó, ł, etc.

    How to display latin letters correctly, i’ve tried lots of fonts included in the Crossfit theme, but all i’ve tried display those characters in different styles which looks awful.

    Please help

    Thank you

    Hi,

    we’ve tested it on our demo website and it’s working without any problem:

    http://web-rockstars.com/crossfit/?page_id=4137

    Please make sure you use a font that support polish letters. You can find the fonts here:

    https://www.google.com/fonts#ChoosePlace:select/Script:latin-ext

    Maybe i didn’t specified my problem correctly. I don’t have problems with latin letters with text in body document (http://web-rockstars.com/crossfit/?page_id=4137) – this looks fine, and my documents also looks good.

    But take a look on site i’m working on – , just under slider you will find text “Zajęcia” and more below with the same problem. Same with names of Localization sites or any other sites form menu, just look for Żanęcin for example, when you open this link, Żanęcin name on the top is totally wrong.

    Font is Raleway, which I already checked on site you’ve linked (https://www.google.com/fonts#ChoosePlace:select/Script:latin-ext) and it should works fine, but it’s not.

    Thank You

    – missed link

    mariatrener.pl

    Hi,

    we’ve checked the pages and all looks ok. What browser do you use?

    Safari on my Mac with OSX 10.9.1 but on my iPhone6 or on my iPad2 it also looks like broken text. I don’t have a PC to test it, but I have also installed Mozilla Firefox on my Mac and texts are still broken.

    No matter what we try, there is no problem on our end. Can you post a screenshot?

    Sure. I made a sample page with two screenshots. Here’s link to it:

    http://mariatrener.pl/sample-page/

    Thanks You

    Very strange, on our end it’s working without any problem. The problem is the “ę” and the “Ż” sign for example, right?

    The problem is with every latin letter. I’ve placed those two screenshots because in word Żanęcin there are two different letters and one is capital, one is small. I have problem in every page name with latin letters. My wife have a phone with android system and there everything looks good, but this should work on every platform right ?

    Hm, ok, let’s try this. Please open the file functions.php in the theme folder and add this:

    add_action( 'wp_head' , 'sl_fix_font' );
    function sl_fix_font() {
     ?><link href='https://fonts.googleapis.com/css?family=Raleway&subset=latin,latin-ext' rel='stylesheet' type='text/css'><?php
    }

    I think this should solve the problem. Looks like in Mozilla is a problem with the url parameter for the Google API url.

    By the way: we don’t saw the problem because we’ve installed Raleway on our localhost, in this case the browser use the local copy of the font…

    Thank You so much, this helped !!!

    I have another question … with blog section. When can I change name of the blog site ? I’ve added new post 2 days ago and now blog site name is not “Blog”, it is now the name of my new post, I cannot find where can I change this.

    And one more question about the posts:
    2 days ago my new post looks fine, yesterday i’ve added only a photo to it, and today background colour is different. Same thing with contact page which was not edited at all for more than 3 days. Yesterday both pages were good, today both are with changed background colour :O Why is like that ? Again I did not make any changes to background colour, but it is changed !

    Here is a screenshot – http://mariatrener.pl/sample-page/

    And here is link to pages with dark colour background (yesterday background was white):
    http://mariatrener.pl/dieta-ziemniaczana/
    http://mariatrener.pl/contact-page/

    And one more question about the posts:
    2 days ago my new post looks fine, yesterday i’ve added only a photo to it, and today background colour is different. Same thing with contact page which was not edited at all for more than 3 days. Yesterday both pages were good, today both are with changed background colour :O Why is like that ? Again I did not make any changes to background colour, but it is changed !

    I remember another client with the same problem. There is a widget included in the timetable plugin, unfortunately there is a HTML error when on the current day is no course, and this cause this problem. Next time when the error occur, you can try to remove this widget, I think this will remove also there problem.

    I have another question … with blog section. When can I change name of the blog site ? I’ve added new post 2 days ago and now blog site name is not “Blog”, it is now the name of my new post, I cannot find where can I change this.

    Normally when you edit the page, there is a box with settings, please click the “Headline” tab, there you can add the page title.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.