Home Forums Theme support Celano – Allslider: link doesn't work

This topic contains 7 replies, has 2 voices, and was last updated by  7Theme Support 5 years, 2 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • Hi!
    I have a problem with linktarget. I found information about similar problem here http://7theme.net/forums/topic/justness-allslider-does-not-link/ but… I set cycle slider at page with slider -> “Slideshow” -> “Slider type” and it still don’t work. I have no idea how to fix it.

    Hi,

    what exactly is the problem? Do you want to open the link in a new tab? The slider itself is working? Can you send us a link to the page with the problem?

    I’m sorry for mental shortcut. I set allslider on main page. I would like to set a link to “x” tab after click to one of the picture. I know that I should choose cycle slider and set it here -> “Slideshow” -> “Slider type”. I also know that mentioned link to the tab “x” I can set in Allslider . Here you have link do website:

    http://tiny.pl/g71sc

    http://postimg.org/image/6r41cqvi1/
    http://postimg.org/image/h1ucbezlz/c57f5cd1/

    Thank you for your help.
    Peter

    Ah, now I can see the problem, the link is there but it’s not clickable. It’s a problem with the z-index of the layers, but it’s easy to solve. Please go to WordPress admin -> Appearance -> Theme Options -> General -> Extra CSS Content and add this:

    .cycleslider .slider_overlay {
    z-index:inherit;
    }

    This css code should solve the problem

    Thank you, it solve the problem 🙂

    But… may I ask you about one more thing? What should I do to make whole picture as a link to other page (without description “read more” on centre)?

    Hi,

    you can try this css code (add it in WP admin -> Appearance -> Theme Options -> General -> Extra CSS Content):

    .cycle_element a span {
    position: absolute;
    top: 0;
    bottom: 0;
    right: 0;
    left: 0;
    height: 100%;
    width: 100%;
    text-indent:-10000px;
    }
    .cycleslider .slider_overlay {
    position: absolute;
    top: 0;
    left: 0;
    width: 100%;
    height: 100%;
    z-index: 230;
    max-width:100%;
    }

    Unfortunately this code doesn’t work.

    Yes, you are right, but it’s not working because there is another layer for the prev / next icons, this layer will always cover the slider, that’s why it’s not working. I’m sorry…

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.